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Working with Excel 

1. Understanding the Ribbon 

It really helps to get to grips with the Excel terminology as it makes like a lot easier to find things & 

understand instructions when using the Microsoft Excel help feature or the internet for help. 

 

The Ribbon is made up of five basic components: the Quick Access Toolbar, tabs, groups, command buttons, 

and dialog launchers. 

 The Quick Access Toolbar is essentially a customizable toolbar to which you can add commands that 
you use most frequently. 

 Tabs contain groups of commands that are loosely related to core tasks. It helps to think of each tab as 
a category. 

 Groups contain sets of commands that fall under the umbrella of that tab’s core task. Each group 
contains buttons, which you click to activate the command you want to use. 

 Dialog launchers are activated by clicking the small arrow located in the lower-right corner of certain 
groups. Clicking any dialog launcher activates a dialog box containing all the commands available for a 
given group. 

 Command buttons when clicked launch a macro which perform a specified action in Excel. 

2. Getting help 

If you can’t remember where to find a function in Excel, use the search function at the top to get assistance. 

 

http://www.google.co.uk/url?sa=i&rct=j&q=&esrc=s&source=imgres&cd=&cad=rja&uact=8&ved=2ahUKEwjb8ObS87fnAhVCQhoKHSchA80QjRx6BAgBEAQ&url=http%3A%2F%2Fwww.informit.com%2Farticles%2Farticle.aspx%3Fp%3D2067634&psig=AOvVaw2C9kVlXoJORUM3kmstdKTm&ust=1580905926307341
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3. Correcting mistakes 

Microsoft Excel tracks all the changes you make to a file, if you make a mistake (or two!) you can step 

yourself backwards through the changes you made to reverse anything you did wrong.  

 

4. Different Versions of Excel 

There are several different version of Microsoft Excel, be aware that different versions offer different 

features and existing features might be accessed via different means.  

These different versions & how they look on a laptop versus a PC means that the screen prints in this 

document might not always look exactly the same as the screen in front of you.  But the features will be 

there so look for the icons which remain consistent or use the search feature to find them. 

Microsoft 365 

Make sure you have the latest version of Microsoft 365 (10 free licences if NFP)  

Microsoft Office 2016 & Later 

You can get buy a licence from charity digital for £33 for Microsoft Office 2019. . 

Microsoft licencing is done on a 2 year open licence which means you get upgrades so check before buying 

anything in case you are eligible for an upgrade rather than paying extra when you want to upgrade to a 

newer version. 

1.Click on Undo 

arrow to go back a 

step. You can 

continue to step 

back multiple times. 
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Viewing Spreadsheets 
Working with workbooks with large amount of data in each sheet can be very unwieldly. Before starting it’s 

worth getting your view sorted out so that you can easily move around between worksheets. 

5. Format tabs 

 

 

6. Freeze panes  

 Allows you to control areas of the spreadsheet to be fixed as you scroll. 

 

 

1.Click on the View tab 

2.Click on the arrow on 

the freeze panes 

command button 

3. Select how you want 

to freeze panes 

1.Right click on the sheet tab to reveal 

formatting options: Rename, Move & Tab colour 
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7. Unfreeze panes 

 

8. Hide columns  

Hiding columns from view can be very useful when working with big spreadsheets so that you only work with 

the columns you need. 

 

1.Highlight the column you want to 

hide by clicking on the letter at the top 

of the column 

2.Right click with your 

mouse and select Hide 

1.Click on the View tab 

2.Click on the arrow on 

the freeze panes 

command button 

3. Select Unfreeze 

panes 
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9. Unhide Columns 

 
 

10. Resize columns 

 

 

 

 

 

 

 

 

 

 

  

1. Highlight the columns on either 

side of the hidden column by 

clicking and dragging across the 

top of the columns. 

2. Right mouse click and 

select Unhide 

2. Hover with the mouse 

between columns. When 

the mouse pointer changes 

drag the column to the 

width you want or double 

click for it to automatically 

resize. 
1. Select the columns you 

want to resize 
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11. Wrap text 

Wrap text allows you to display a long line of text on multiple lines so that it can all fit in one cell. 

 

 

1. Select the cell where you 

want to wrap the text 

2. Click on Wrap Text 
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Managing data with tables 
The advantages of an Excel table include all of the following: 

 Quick Styles 

Add color, banded rows, and header styles with just one click to style your data. 

 Table Names 

Give a table a name to make it easier to reference in other formulas.  

 Cleaner Formulas 

 Excel Formulas are much easier to read and write when working in tables. 

 Auto Expand 

Add a new row or column to your data, and the Excel table automatically updates to include 

the new cells. 

 Filters & Subtotals 

Automatically add filter buttons and subtotals that adapt as you filter your data. 

 Dynamic Pivot tables  

If you use an Excel Table for the source data of your pivot table, the data range becomes 

"dynamic". A dynamic range will automatically expand and shrink the table as you add or 

remove data, so won't have to worry that the pivot table is missing the latest data. When 

you use a Table for your pivot table, the pivot table will always be in sync with your data. 

12. Make your data into a table 

 

 

1. Click on the 

Insert tab  

2. Click on the 

Table command 

button  

3.  A window will open. 

Confirm the cells to be 

included in the table and that 

the data has headers 
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13. Naming the table 

It is good practice to name the table as it makes life much easier later when working with formulas. Naming 

the formula is basically giving your data set a name which will enable you to recognise which data set you 

need to be working with. 

 

 

14. Formatting the table 

There are a number of table formatting options in Excel. The benefit of the table format is that it ensures 

each new column or row you add to your table will be automatically formatted in the same way. 

 

  

1. Click on the table & select 

the Design tab 

2. Rename the table. For 

example, “Participants” 

Change the look and feel of 

your table with the formatting 

tools 
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15. Sorting (Single level) 

Simple sorting can be done using the options available in each column header. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  

1. Click on the arrow in the column 

header of the column you want to 

sort 

2. Select Sort A-Z or Z-A for text or Smallest 

to Largest, Largest to Smallest for numbers 

& dates 
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16. Sorting (Multi-level) 

More complex sorting options are available via the Home tab including: 

 Multi-level sorting 

 Custom sort orders 

 

 

 

 

1. Click on the Home tab  

2. Click on the Sort & Filter 

command button 

3. Click on Custom Sort 

4. A window will open. Select the column you want to sort by, the 

value to sort by and the sort order for the first level of sorting. 

5. Click on OK 
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17. Clear sort order 

 

 

 

2. Click on Sort & Filter 

3. Click on Clear 

1. Click on the Home tab 

6. Click on + Add level to add a secondary sort level. For example, 

here we are sorting by prison name and then by participant name. 
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18. Filtering (Select & Deselect) 

 

  

1. Click on the arrow next to the column 
header of the column you want to filter by 
 
 

2. Select the values you want to filter by 
 
 

When you have applied the filter, look at the bottom of the 
sheet to see the total count of the filtered rows. 
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19. Filtering (Text filters) 

Excel has more advanced filtering options available via text filters: 

 

 

3. A Custom AutoFilter 
window will open. 
 
 

4. Check the 
filter type 
correct 
 
 

5. Enter the value 
you want to filter by 
 
 

1. Click on the arrow next to 
the column header of the 
column you want to filter by 
 

2. Select Text Filters 
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20. Data Slicers 

Slicers are visual filters. Using a slicer, you can filter your data (or pivot table or pivot chart) by clicking on the 

type of data you want. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1. Click on the 
Insert tab 
 
 

2. Click on 
Slicer 
 
 
 
 
 

1. Insert Slicer 
window will open. 
 

2. Select the 
column(s) you would 
like to use for 
filtering 
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4. Select a single filter 
option to apply the filter 

5. To add more than one 
filter click on the Multi-
Select button  

6. Select multiple filter 
options to apply  

3. Drag and drop the slicer to 
the location you want 
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Creating a workable data set 
You don't always have control over the format and type of data that you import from an external data source 
or over internal data entered by different users in different ways. Before you can analyze the data, you often 
need to clean it up in order to create a robust data set.  
 
To create a robust and workable dataset you need to ensure that your data has: 
  

 No Duplicate records 

 Unique Record Identifiers 
 Accurate data entry – No spelling mistakes, spaces, extra punctuation that shouldn’t be there 

 Consistent data entry  - Spelling, punctuation, layout of data is the same for similar bit of data 

 Correct format - Fields are formatted correctly for the data type you're using  & data is a format you 
can use 

 Consistent format  
 No missing data (what does a blank mean?) 

 

Before you begin working with data, take a back up to ensure if you make a mistake you 
can revert to the original.  
 

21. Identifying duplicates 

Use the Highlight duplicates function in Conditional formatting to identify duplicates 

 

1. Highlight the 

column you want to 

search for duplicates 

and then  on the 

Home tab 

2. Click Conditional 

Formatting 

3. Click on the arrow next to 

Highlight Cells Rules 

4. Click on Duplicate 

Values 
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6. The Duplicate Values window will 

open giving you the opportunity if 

you want to highlight Duplicate or 

Unique values and what colour you 

wish  
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22. Removing duplicates 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4. Select the columns you want 
to remove duplicates from (the 
whole row containing the 
duplicate will be deleted 

1. Click anywhere on the 
table to select it 

2. Click on the Data tab 

3. Click on the Remove 
Duplicates command 
button 

5. The number or duplicates 
removed will be displayed in a 
window. If you realise you made a 
mistake, use the Undo button. 
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23. Adding a unique reference number  

After having removed all duplicates it’s good practice to give all your rows of data a unique reference 

number, that way how ever much you sort and filter them you can always return to the original order. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1. Right mouse click on the 
table to display the menu 

2. Select Insert & Table 
Columns to the Left 

2. Rename the column 
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24. Changing field formats 

 

 

 

 

 

 

 

 

 

 

 

1. Using the + cursor, drag the 
content down the column  

2. Click on the arrow to display 
the menu  

3. Select Fill Series to generate 
sequential reference numbers 

2. Select the column 
you want to format  

1. Click on the 
Home tab  

3. Click in the Field 
format field and select 
a format 
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25. Find & Replace  

Find and Replace can be used to bulk correct data. For example, a constantly repeated spelling mistake. 

 

 

 

 

 

 

 

 

 

26. Splitting columns  

Often there is a need to break down data to make it easier to work with. For example, if you want to sort 

people in alphabetical order using their surname you will need to make sure their name is split into first 

name & surname columns. 

 

 

*space before a name so that count if doesn’t work -bring it back as an exercise in the formulas. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1. Click on the 
Home tab  

2. Click on the 
Find & Select 
tab  1. Click on the 

Home tab  

3. Select Replace  

4. Enter Find what 
& Replace with 

5. Select Replace All to replace 
all instances 

1. Click on the 
Home tab  

2. Highlight the 
column to split  

3. Click on the Text 
to Columns 
command button 

4. The Convert Table to 
Columns wizard will open  

5. Select Delimited & then 
click on Next  
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A Delimiter is a blank space, comma, or other character or symbol that indicates the beginning or end of 

a character string, word, or data item 

 

 

 

 

 

 

 

 

 

 

 

 

 

27. Data Validation  

The Data Validation feature in Microsoft Excel controls what can be input into a cell to ensure accurate and 

consistent data. Here we’re  

1. Ensure Correct data format 

2. Limit data entry options to a list 

 

6. Select what delimiter to use to 
separate the data into columns. In this 
example the data to split is separated 
by a space 

7. The wizard displays how 
the text will be split 

8. Select the data format for each 
column. General automatically 
converts the column to the most 
appropriate format. You can 
override that now or later after 
the split 

9. The wizard makes the assumes 
you wish to replace your single 
column with your new double 
column. Changing the destination 
cell enables you to keep the 
original column and create the 
new double column elsewhere 
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Data Validation for data format 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1. Click on the Data tab 

3. Click on the Data 
Validation command button 

2. Select the column 
to validate 

1. Specify what type of 
data is allowed. 

2. Chose validation 
method 

3. Define parameters 

4. An error message will appear if data outside of 
the parameters is entered. Here the year doesn’t 
meet the requirement of being post 1980. 
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Data Validation with list options 

1. Follow the steps as above to 

access the data validation options 

2. Select List 

3. Enter the data entry list with 

each item separated by commas 

4. A selection list drops down for 

data entry 
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Formulas & Functions 
 

In common business practice, Excel users use the terms formula and function almost interchangeably. From 

a communication and comprehension perspective, there’s not a big difference. But technically a function is a 

piece of code that executes a predefined calculation, while a formula is something you create yourself. 

28. Calculations 

There 4 most frequently used calculation functions in Excel are: 

Sum 
Adds up the total value of the cells selected 

Average 
Returns the mean average of the cells selected. The mean average is calculated by dividing the sum of the 

values in the set by their number. 

Max 
Returns the largest or highest value in the cells selected. 

Min 
Returns the smallest or lowest value in the cells selected 

 

 

 

 

 
 

 

 

 

 

1. Select the top row of the data you 

want to calculate 

2. Click on the Auto Sum command button. 

& select the type of calculation you want 

3. Excel calculates the total 

column for the whole table 
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29. Formulas & Operators 

Formulas are built using operators which define what action you want to take.  

Common Operators in Microsoft Excel 

Plus + 

Minus - 

Multiply * 

Divide / 

Equal to = 

Not Equal to <> 

Greater than > 

Greater than or equal to >= 

Less than < 

Less than or equal to <= 
 

 

 

 

4. If you want to continue 

adding calculated totals, 

highlight the data set again. 

5. Click on the Auto Sum 

command button. & select the 

type of calculation you want 

6. Excel automatically puts 

the next calculation in the 

next column 

7. Use the decimal place 

command buttons to increase or 

decrease decimal places 
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Always start with an = and then the order of operations is Divide (/) Multipy (*) Add (+) Subtract (-).  To 

‘force’ Excel to do differently – use Brackets e.g. 

5+3*2  = 11 

but… 

(5+3)*2 = 16 

 

30. Copying formulas 

Formulas can be copied from one cell to the next by selecting and dragging the highlighted field down. 

31. Absolute Cell references 

Sometimes, instead of your formulae automatically updating its references as you copy down / across on a 

spreadsheet – you may want to include a fixed element in your calculations.   

To do this use the $ operator before the letter and number cell reference e.g. $A$D  

  

1. Click in the field where you want the 

formula answer to appear and enter the 

formula in the formula pane 
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32. Age calculation formula  

Here is the formula for calculating a person’s age from their date of birth. The D2 in this formula applies to 

the D2 cell reference in the screen print below, the first date of birth cell in our Date of birth column. To 

adapt the formula for your data copy the formula into the first cell in your age column and replace the 

highlighted D2 with the first cell reference in your date of birth column 

=YEAR(TODAY())-YEAR(D2)-IF(D2-DATE(YEAR(D2),1,1)>TODAY()-DATE(YEAR(TODAY()),1,1),1,0) 

 

33. IF formula 

The IF formula checks whether a condition is met and returns one value if True and another if False 

In the example below,  if a 2 point increase in optimism, as shown by the Difference column meant your 

target was met you could use the following formula to return if the target was met or not: 

 If(E2<2,”No”,”Yes”) 

 

34. Count If 

Used to count the number of cells that meet the criteria 

=COUNTIF(D2,“*guitar*") 
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Pivot Tables 

35. Creating a pivot table 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 This will automatically update the table as below, now displaying dates across as columns 

 

 

 

 

 

 

 

1. Click on the Insert tab  

2. Click on Pivot Table 2. Select the table you want to base the pivot table 

on. Here you can see the table name “participants”. 

Using a table ensures you have a dynamic data source 

for your pivot table 

3. Select New Worksheet  
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6. To create a simple pivot table that 

shows the number of prisoners attending 

sessions from each prison drag and drop 

the Prison field into the Rows box and 

the Name field into Values 

 

7. The pivot table now displays how 

many prisoners attended the music 

sessions from each prison 

8. As the name field is text the pivot table 

assumes you want to Count the number of 

records in the Name 

4. An empty pivot 

table is created 

 

 

 

 

 

5. The columns from your 

table appear in the fields 
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36. Field values 

 

 

9. Add complexity to your 

Pivot table. To show how 

many of the attendees from 

each prison already had 

musical experience, add the 

field Musical experience to 

the Columns field 

 

 

 

 

 

 

 

 1.Highlight the fields you want 

to display as a percentage. 

 

 

 

 

 

 

 

 

2. Select Show Values As and 

then % of Grand Total 
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37. Sorting & Filtering a pivot table 

Simple sorting and filtering work exactly the same as elsewhere in Excel. 

 

 

 

 

 

 

 

 

 

 

 

 

  

Click next to the row or 

column heading for sorting 

and filtering options 

3. Percentages 

replace the 

original 

numbers 

 

 

 

 

 

 

 

 

4. Use the Decrease decimal 

place command button to 

round numbers. 
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38. Add a Slicer to a pivot table 

 

39. Formatting a pivot table 

Like Tables, Pivot Tables can be formatted.  

 

 

 

 

 

 

 

 

  

1. Click on the pivot table and 

then on the Design tab 

2. Add and remove specific headers 

or banding for rows & columns 

3. Change the format (colours, 

banding, outline etc) 

1. Click on Insert Slicer 
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40. Refreshing data in a Pivot table 

If you make changes to the data set being used to the pivot table, you might need to refresh the chart so 

that the changes are immediately reflected in the chart. 

 

41. Recommended Pivot Tables 

A short cut to creating pivot tables can be to use the recommended Pivot table function. 
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42. Pivot table charts 

 

 

 

  (red for any less than 2)  

 

 

 

 

 

 

 

 

1. Click on the pivot table and 

then on the PivotChart 

command button 

2. Choose the chart type 

 

 

 

 

 

 

 

3. Choose the chart format 
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Presenting your findings 

43. Conditional Formatting 

Colour scales 

Icon sets 
 

 

44. Printing  

In the print preview screen you can review your data before printing it. 

1. Highlight the cells you want 

to highlight & click on 

Conditional Formatting 

 

 

 

 

 

 

 

2. Under Color Scales, select 

the colour range 

 

 

 

 

 

 

 

1. Highlight the cells you want 

to highlight & click on 

Conditional Formatting 

2. Under Icon Sets, select the 

icons 
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Make sure the orientation is 

correct for the data set 

 

 

 

 

 

 

 

Scaling allows you to fit all the 

columns and rows on one 

page 

 

 

 

 

 

 

 

Select Page Set Up to add 

headers and footers to pages 

 

 

 

 

 

 

 Select Header/Footer to add 

in automatic or custom 

headers and footers 

 

 

 

 

 

 

 


