wf/
\,:v'

\,,)y

Superhighways training, June 2021

superh|ghwoys

harnessing tec for community benefit

Excel for monitoring & evaluating impact

Contents
1) FrEEZE PANES ..ottt sttt b bt s h e bttt a bbb b et ettt neens 2
2)  HIde COIUMNS........uiiiiiciiieiee ettt b et et b etk et e b et e bt eb e e e b e s besbeneasene 2
3] SOMLING .ttt bt h e bt b Rt R bkt h et b et bbbttt 3
4)  SPIILEING COIUMNS ...ttt ettt st st et et et et e st e seesesbeste s eaeneeneenenseas 4
B)  FHIEEIING ...t h e bt b ekt b ettt b ettt ae e 5
6)  PHINEING ...ttt b et b e bbbt b bbb Rtk e st be et b ettt ae e 6
7) Basic calculations & fOrMUIAE ..............ccoiiiiiiiiiiieee st 8
8)  COPYING FOrMUIAE .......ceiiiiiiiieeee ettt sttt ettt aesbesbesbeste s eneeneeneenenseas 8
Q) ADSOIULE Cell FEFEIENCES ........c.cviniiinicieiei ettt sttt ettt be et be e 9
TO)  AUBOSUM . ..ottt b bbbt b bbbt b et s et et e b ettt e b et eb s b e 9
11)  Age calculation fOrMUIA.............oooiiiiiiecee ettt enes 9
12)  AVErage & IMaX [ IVIIN ........coouiiuiiicieeieeeee ettt ettt ettt st e st e s e s seeseeseebeetesbesse s enseneeneanis 9
T3] COUNTIF ...ttt ettt et ettt e et et e s te st e e e s e e st e s e e s e ese e b e st e s enseseeseeseeseetessassensenseneesennin 9
L I | USROS 10
15)  RemMOVE dUPIICALES.......c..cueeeiciiciiiiciecteeceeee ettt sttt e s e beeaestesaesbeseseeseenens 10
16)  Conditional fFOrMAttiNg ............ccociiiiiiiiieicicccecece ettt s tesae st s seeseeneas 11
17)  Validating data @NTrY .........c.oooiiiiiiieeeeeeese ettt ettt testessenteseneeneeneas 12
18) Summary sheets / dashboards — linking Sheets ...............ccceceeiririnenenciee e 13
T9)  QUICK @NAIYSIS ...ttt et s b et eere et ae st e s e ae s eneereereas 14
20)  PIVOT TABIES........oiiiiiiiieie ettt 15
21)  PIVOT CRAIS ...ttt be st et et e e et e e e seeseesesteebentesenee e eneenenneas 18



N

2)

Superhighways training, June 2021

Freeze panes - allows you to control areas of the spreadsheet to be fixed as you scroll.

a. Go to the View tab and select Freeze Panes (click arrow at bottom right for this to
drop down as below)

H = Excel demao - Excel
FILE HOME INSERT PAGE LAYOUT FORMULAS DATA REVIEW VIEW
T = D = split |
+| Formula Bar Q I:E) T"_J E Igl |
I:I D IDJ o] Q [ T Hide —
Normal Page Break Page Cu.:tnm 7| Gridlines [/] Headings Zoom 100% Znnm. to New t-\rr.ange Freeze "Swwtch
Preview Layout Views Selection  Window Al Panes= Windows
Workbook Views Show Zoom Freeze Panes
gl Keep rows and columns visible while the rest of
V4 A f the worksheet scrolls (based on current selection).
Freeze Top Row
A B c D E F G i I;I Keep the top row visible while screlling through
1 Family number First name Surname Address line 1 Address line 2 Town Post code Status the rest of the warksheet. i
2 12 Julie Stanley SM11BA Inactive Freeze First Column 8
- Keep the first column visible while scrolling
- 3 Tracey MacRae SM11AX |Curreni through the rest of the worksheet.
4 2 Claire Evans SM11AD Current s

b. Now select either to freeze the row above and to the left of the cell your cursor is
in — or alternatively just to freeze the first row or first column.

Hide columns is a way of only seeing data you need — and very useful if your
spreadsheet has lots of columns.

a. Highlight the column/s you want to hide by selecting the column letter/s at the
top and if more than one - dragging across

b. Nextright click and select Hide

H o-
FILE HOME INSERT PAGE LAYOUT FORMULAS DATA REVIEW VIEW

i &= @Emm 1

% [ Height 1§

Margins Oricntation Size  Print Breaks Background Print
- - - Aear - Titles

Themes Page Setup o Scale to F
D1 - fe | Addressline1

A 8 CHN N E—r T AN
1 |Family number Firstname Surname Address line 1 |Addre =5
2 12 Alison Stanley = f T
3 9 Becky MacRae lsnn
4 2 chris Evans 3 Cut 1
5 5 Christine  Scott B Copy L
6 10 Claire Smith ‘4 Paste Optiofs: L
7 18 Healah Siddig < L
8 33 Clare Woodhouse D 4
9 42 Daniella Collins Paste Specialy. 2
10 43 Dominigue  Foster Insert 1
11 8 Donna Turner 1

Delete
12 13 Nicky Allison 1
13 24 Jackie Godowska Clear Coptent 3
14 36 Jane Hunt Format Cells. 1
15 45 Janina Ward Column Widtd, 1
16 1 Janine Bond Hide L
17 6lJo Soares L
Unhide

18 11 Joanna Green . 1§

c. To Unhide - select the columns either side of the hidden columns and then right
click again and select to Unhide.
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3) Sorting column information.

a. First select the column you want to reorder, then go to the Data tab and select
the AZ| option.

b. You will then see a warning box asking — Do you want to expand the selection?
This is to safeguard against just sorting this column in isolation (i.e. not rearranging
the other column information in line with this one — ending up with rows of
information being mixed up).

ySortWarning @1

selected this data, it will not be sorted.

What do you want to do?

Microsoft Excel found data next to your selection. Since you have not

! Continue with the current selection

| sot || cancel |

A safer option is to select the whole sheet (highlight the top left hand cell) and
then select the Sort icon in the Data tabs, as below

H

UM HOME  INSERT  PAGELAYOUT — FORMULAS  DATA A REVIEW
L&l Connections *

®lsly 3 B 2 21 (23

From From From From Other
Access Web  Tedt Sources~

Existing  Refresh z| Sot  f
Connections  All -

Get External Data Connections Sor

d. The Sort dialogue box opens up and here you can select the Columns that you
want to sort. Remember to tick the My data has headers box if relevant.

Sort 7|3l
[ El Add Level “ x Delete Level “ EE Copy Level I I Options... J D My data has headers
Column Sort On Order
Setby  Column F [=] values =] Atz =]

e. You can Sort by any number of criteria by selecting Add level.

Sort

-2 |

l 2] Add Level H ){Qelete Level “ EE Copy Level ”E]

Options...

My data has headers

Column Sort On
Sortby | pate IE‘ Values
=] |values

In the example above — we’ve chosen to sort by Date - Oldest to Newest and

Order

El Oldest to Newest

[=] |atoz

then alphabetically by Organisation name.

[=]
[=]




4) Splitting columns of data
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a. Highlight the column you want to split, go to the Data tab and then select Text to

Columns
@B H S =

Excel demo - Excel

(2003 HOME INSERT

PAGELAYOUT ~ FORMULAS  DATA  REVEW  VIEW  NitroPro8
[&] Connections Clear L i Ea v
BHE L B e =
From From From From Other  Exsting  Refresh o 7| St Filter Tetto Flash Remove  Data
Access Web Tedt Sourcesw Connections  All~ Edit Links TrAdvanced  Columns  Fill - Duplicates Validation -
Get External Data Connections Sort & Filter Data To
L . # | kate white Text to Columns
Split a single column of text into
multiple columns.
For example, you can separate a
A 8 c D £ F G H 1

Kate White
Sorrel Parsons.
Sue Quilter
Colin Cregan
Nine Htet
Philippa Leary

e AW N R

column of full names into separate
first and last name columns.

You can choose how to split it up:
fixed width or split at each comma
period, or other character.

@ Tell me more

b. Now check the Delimited option is selected and then click Next

Convert Text to Columns Wizard - Step 1 of 3 -7l
The Text Wizard has determined that your data is Delimited.

If this is carrect, choose Next, or chaose the data type that best describes your data.
Original data type

Choose the file type that best describes your data:
@ Delimited

- Characters such as commas or tabs separate each field.
©) Fixed width

- Fields are aligned in columns with spaces between each field.

Preview of selected data:

0lin Cregan
|5 bine Htet

c. Now select the appropriate Delimiter which in this case is the Space option

between first and second name, and then click Finish

Convert Text to Columns Wizard - Step 2 of 3 =

This screen lets you set the delimiters your data contains. You can see how your text is affected
in the preview below.

Delimiters

0

l:‘“sam\(n\on [#] Treat conse imiters as one
Comma

; ext qualifier: - [
Space

[] other:

Data preview

ate ite -~
orrel [Parscns 3
ue ilter b
olin [Cregan

ine tet

Concel | [ <Bacc | [ meas> | [ Finish
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5) Filtering data allows you to see a subset of your data (in terms of rows) based on criteria
you select.

a. Select the column containing the data you want to Filter on, then select the Data
tab and click on the Filter icon

H ©- - Bookl
FILE HOME INSERT PAGE LAYOUT FORMULAS DATA W VIEW Nitro Pro
r [=] Connections ,e,l H Y Clear
[&1 [E“ [E D:} D ra Properties ) Reappl
From From From From Other Existing Refresh o zl Sort Filter '
Access Web Tet Sources~  Connections  All~ Edit Links ' Vo Advanced
Get External Data Connections Sort & Filter

b. There should now be a drop down arrow in the header cell for that column

B C G

1 |Firstname Surname Post code Status * MNo. ¢
2 |Alison Stanley SM1 1BA |Inactive

3 |Becky MacRae SM1 1AX |Current

4 |Chris Evans SM1 1AD |Current

5 |Christine Scott SM1 3NQ |Waiting list

6 |Claire Smith SM1 1AY |Waiting list

7 IHealah Siddin ST 1BN ICurrent

c. If you click on the down arrow you can then select / deselect the options you

want to filter on

B d G H

1 [Firstname Surname  Postcode Status |~ |N
2 |alison | 4] SotAtoZ

3 |Becky (7| SgiZtoA

4 fchris Sart by Color v
5 |christin

6 |Claire

7 |Healah

8

Clare Test Filters
9 [Daniellz
Search
10 |Dominic e £
) ect All
- rrent

11|Donna

12 | Nicky
13 |Jackie
14|)ane

15 [Janina
16 Janine
17 Jo
18|Joanna
19 [Julie
211Runeel ki

d. The Filter icon then displays in place of the down arrow to indicate a Filter has

been switched on



B
1 |First name
2 |Alison
17 |1o
18 |Joanna
21 |Rupeeka
22 |Kathleen
23 |Kathy
31 IMireide

C
Surname
Stanley
Sopares
Green
Riazi
Ghuman
lenkins
Williams

G

H

Post code Status

SM1 1BA
SM11aD
SM1 1AZ
SM3 8BJ
SM32 BBP
SM5 1HP
SM2 TPY

-

Inactive
Inactive
Inactive
Inactive
Inactive
Inactive
Inactive
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6) Printing - there are a number of options to make printing spreadsheets easier and

importantly easier to read.

a. To set it so that row or column headers repeat when printing across a number of
pages (much like the Freeze pane option for viewing on screen when scrolling) —
go to the Page Layout tab and then select the Print titles option

b. Now put your cursor in the ‘Print titles — Rows o repeat at the top’ box and then

highlight the header row in your spreadsheet

yd

r ~
Page Setup / l P |-
| Page I Margins I Headeu’F(yér | Sheet |
Print area: Rz
Print titles
Bows to repeat at top: 51:51 R
Columns to repeat at left: Rz
Print
[T] Gridlines Comments: [None) IZ|
[T] Black and white -
. Cell grrors as: | displayed IZ|
|:| Draft guality
|:| Row and column headings
Page order
@ Down, then over |==g= ===
— T EERE A=E
() Oyer, then down | ==f=fi==
EE dIE' 38
[ Print... ] [ Print Preview ] [ Options... ]
’ QK ] ’ Cancel ]

c. Now select Print Preview to check before selecting Print.
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d. To just print part of your worksheet, select the area you need and go to Print and

then choose Print selection

Printer

, 7 Send To OneNote 2013

) Ready

Printer Properties

Settings

Print Active Sheets
Only print the active sheets

D Print Active Sheets
Only print the active sheets
Q Print Entire Workbook

Print the entire workbook

E| Print Selection
Only print the current selection

Ignore Print Area

-

Account

Options

e. If you have a large spreadsheet you might also want to use the Scale to print
options.

f. Select the drop down arrow from the bottom option - Fit Sheet on One Page
and choose the best option for the size / shape of your spreadsheet.
(If you go to the Page Layout tab you can also adjust margin sizing)

Settings

| o s | Dieiwmd A mbin s Tl mmde

3 Mo Scaling
Do Print sheets at their actual size

& Fit Sheet on One Page
Account *[ 3¢ | Shrink the printout so that it fits
on one page

Options Site Fit All Columns on One Page
ﬁ Shrink the printout so that it is
one page wide

Fit All Rows on One Page
[EHE  Shrink the printout so that it is
one page high

<> _&

Custom Scaling Options...

¥
o e Fit Sheet on One Page
L Shrink the printout so that it...

L

Page Setup
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Basic calculations & formulae
Always start with an = and then the order of operations is Divide (/) Multipy (*) Add (+)
Subftract (-). To ‘force’ Excel to do differently — use Brackets e.g.

7)

5+3*2 =11
but...
(5+3)*2 =16

Check the Formula bar to see if your formula is correct

B HS- Copy of DaviesandSons report_with percentage [Compatibility Mode] - Excel 7 H - 6 X
FILE HOME  INSERT PAGELAYOUT | FORMULAS  DATA  REVIEW  VIEW Kate White -
% Cut .o = =, -I' Tim T [ X Auosum v A
o0 Avial 10 A A T == #- E'WapTet Currency 8 7] 4 e = ; A H
F copy - 2 ol C d I Format (‘u IEEIrt DEEIIEt Format Wi~ Szrt& Find &
N BIu- 7. M aA. === == HMeagesiCenter - 57« % » % £ Conditional Formatas Cel nsert Delete Forma o in
¥ Format Painter 4 B Merge & Conter N ® % Formatting~ Table~ Styles= - - £ Clear~ Filter = Select =
Clipboard 3 Font 3 Alignment I Number [ Styles Cells Editing ~
F7 - f | =ET'D7 v
A B c D E F G H J K L M N o P Q R s =
1 Partime staff. Pay and hours week commencing 12 th March
2
3
4 Note to calculate weekend pay add 10%
5
Sumame  First Date Hourly rate Hours worked Week  Hourly rate - Hours ~ Weekend " Total Pay
name started this week total pay WWeekend  worked - total pay due
6 il weeken
7 |Campbell  Sarah 10/05/1999  £10.50 10 £10500 | £1156 5
8 |Carter Mark 12/09/2002  £7.20 225 4
a. To copy formulae either use the Fill command and then select Down, Right, Up or
BH S TABLETOOLS ~ Copy of DaviesandSans report_with percentage [Swwagatibility Mode] - Excel TG
FILE HOME ~ INSERT ~ PAGELAYOUT  FORMULAS ~ DATA  REVIEW  VIEW DESIGN
o X Cut P = |9 @im Ex EP 3 AutoSum - A,
e Arial -0 - KA E== - EWapTet General = 57 4 £m O u ad H
Em Copy - & # o H I;I [] Filt = .
Paste B I U- ib H-A- === &= 2. gy 5 <7 09 Conditional Formatas Cell  Insert Delete Format ' Sai Find 8
+ ¥ Format Painter == Formatting~ Table+ Styles~ - B ¥ Down i
Clipboard ] Font ] Alignment ] Number & Styles Cells E Right
D39 - £ || =B9*cs &
[€l Left
A B D F G H J K L M N 0] R
1 |DAVIES & SON OFFICE ITEMS |
2 Series...
i Date Justify
a

5 |w/c 3/03/2012
- rerr—

Alternatively select the cell with the formula in and then use the Ctrl D shortcut
and drag to copy Down to cells beneath

Or Select the cell with the formula in and then hover over the filled in square in

the bottom right and when the cursor becomes a + - then drag the box down to
cover the relevant cells and the formula will be copied.

]
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9) Absolute Cell references

a. Sometimes, instead of your formulae automatically updating its references as you

copy down / across on a spreadsheet — you may want to include a fixed element
in your calculations.

b. To do this use the $ operator before the letter and number cell reference e.g.
SASD

AutoSum is used to quickly sum up numbers in a row or column.

a. First highlight the numbers in question and then select the AutoSum icon from the
Home tab (or Formula tab)

B H S

HOME | INSERT ~ PAGELAYOUT ~ FORMULAS ~ DATA  REVIEN  VEW  MitroPro8
oy X s o= _ et F=h 3 AutoSum v A,
B | calibri Sl -|A A S=o ®- EeWmpTet General - = Y T = TEx Ay
M- = B W 22 o E S 4
Pate | B I U- D - A === == EMageacoa - T % » % £ Condiional Formates Cel  Insert Delete Format

s
Formatting~ Table~ Styles= - - - Averag
Clipboard 1% Font c

Alignment e} Number n Styles Cells

F1 - 5 wet !

b. AutoSum will calculate the total and display this in the next cell.

11) Age calculation formula
a. Calculating Age from Date of birth

=YEAR(TODAY())-YEAR(L2)-IF(L2-DATE(YEAR(L2), 1,1)>TODAY()-DATE(YEAR(TODAY()),1,1),1,0)

Remember to change the DOB reference cell which in this case is L2

Average & Max / Min

a. These all work in the same way — highlight the range of cells in question and then
select the Function you need.

13) COUNTIF
a. This is a really useful function to add up numbers of times a certain criteria is

present in a specified range of cells.

b. It uses the following formula =COUNTIF(range, criteria) and the criteria can either
be a number, value or cell reference

c. Select the range of cells and then the criteria e.g. =COUNTIF(H2:H50, R36) or
COUNTIF(H2:H50, “Current”) (this will return the same result where Current is an
entry in the Column H)
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14) |F —this checks whether a condition is met and returns one value if True and another if

False
a. Use the formula =IF(criteria, “option1 to display if frue”, “option 2 to display if
false”)

For example =IF(C3>B3,"Targets met", "Targets unmet")

15) Remove duplicates

a. Another handy way to see how many unique entries are in a column is to remove

duplicates.
b. Highlight the column in question and go to the Data tab and select Remove

Duplicates

B H S = Excel for M&E training workbook - Excel 7 H - & X

FILE HOME  INSERT PAGELAYOUT ~ FORMULAS = DATA  REVIEW  VIEW Kate White -

s Y 3 €rg I

malh B B e 2@ Y = BB =X = B ] 92 85

From From From FromOther  Edsting  Refresh | Sort  Fiter Tetto  Flash Remove  Data  Consolidate WhatIf Group Ungroup Subtotal

Access Web Tet Sourcesw  Connmections  All~ " TeAdvanced  Colymns  Fill  Duplicates Validation - Analysis ~ - -
Get External Data Connections Sort & Filter Data Tools Outline n ~

Remove Duplicates
¥ - f< || Organisation A P v
Delete duplicate rows from 3 sheet

A B c D E F G X [ L M N o P qQ [«
_ — - You can pick which columns should
1 Organisation name Date Initial assessment Final assessment Progress made | be checked for duplicate
31 |Organisation K 21/12/2013 1 4 3 information.
32 |Organisation K 21/03/2014 1 3 2
33 | Organisation L 21/12/2013 1 3 2

c. Select the column with duplicate values and click OK
rF‘.emove Duplicates l ? &1

To delete duplicate values, select one or more columns that contain duplicates.

[ 4= select A1l ] ’ 8= Unselect All My data has headers

Columns
Crganisation name

[ OK ][ Cancel ]

d. Excel will then return the column of data minus duplicates and indicate how

many have been removed.

Microsoft Excel &]

23 duplicate values found and removed; 27 unique values remain.

Was this information helpful?

10
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16) Conditional formatting

a. Select the required column / area of worksheet and then in the Home tab select
Conditional Formatting

H - =

Excel for M&E training workbook students - Excel

“D %sc”t Calibri iz A A E=E % BewepTe Genera By [ Eﬂﬂ = E 2 Autos
Past E@Cupy ) [l +0 o0 Conditi | Fe Dt C‘TI Insert [‘;E:et F t FI”‘
5 Sramarana BT U 5 0 A S S et - T 0 40 G G Dok o
Clipboard F) Font ) Alignment ) Mumber F]
) Highlght Cells Rues » | [T Greater Than..
El - j‘\ Progress made L]
A P c D E E s . Iop;’Bottom Rules » DELESEIM“_ \
1 |Organisation name Date Initial 1t Final 1t |Progress made |
2 |organisation A 21/09/2013 1 3 2 Data Bars v E Between...
3 |Organisation A 21/09/2013 2 2| 1]
4 |Organisation V 21/09/2013 1 3 2 E:I Color Scales » L—|E| Equal To...
5 |Organisation A 21/10/2013 2 3 1
6 |Organisation A 21/11/2013 1 2 1 Icon Sets v |_—| Text that Contains...
7 |Organisation A 21/12/2013 1 4 3
8 |Organisation A 21/01/2014 1 4 3 E NewRule. L_‘ A Date Occurring...
9 |Organisation | 21/02/2014 1 4 3 F3 ClearRules » =
10 | Organisation A 21/02/2014 1 3 2 , .
11 |Organisation A 21/02/2014 1 3 2 [ Manage fules.. l:l Duplicate Values..
12 | Organisation A 21/03/2014 1 3 2 More Rules...
13 | Organisation B 21/11/2013 2 4] 2
14 | Organisation B 21/01/2014 2 5 3
15 | Organisation C 21/12/2013 2 4 2
16 | Organisation C 21/02/2014 2 5 3
17 | Organisation D 21/01/2014 2 3 1
18 | Organisation E 21/09/2013 2 1 -1
19 | Organisation E 21/09/2013 3 5 2
b. There are a number of options including Highlighting Cells based on Rules you
can specify as below (red for any less than 2)
FILE HOME INSERT PAGE LAYOUT FORMULAS DATA REVIEW VIEW
“D f%c“t 12 e Nrap Text L_p.'d ’__9.5 Eﬂj EX E 2‘°‘_“m
Paste B Copy - J [ <o 00 Conditional Formatas Cell Insert Delete Format FIII'
- ¥ Format Painter I B Merge & Center - T % s Formstting = Table+ Stlest -+ - . & Cea
Clipboard [Fl Font Alignment Number Styles Cells
E1 - f\ Progress made
A B C D E F G H 1 J K L M
1 |Organisation name Date Initial 1t Final 1t Progress made
2 |Organisation A 21/09/2013 1 3 2
3 |Organisation A 21/09/2013 2 2 0
4 |Organisation V 21/09/2013 1 3 2 Less Than ? Py
5 |Organisation A 21/10/2013 2 3 1
& |Organisation A 21/11/2013 1 2 1 Format cells thaf are LESS THAN:
7 |Organisation A 21/12/2013 1 4 3 2 with | Light Red Fill with Dark Red Text [ ]
& |Organisation A 21/01/2014 1 4 3
9 |Organisation | 21/02/2014 1 a 3
10 |Organisation A 21/02/2014 1 3 2
11 Organisation A 21/02/2014 1 3 2
12 |Organisation A 21/03/2014 1 3 2
13 |Organisation B 21/11/2013 2 4 2
14 |Organisation B 21/01/2014 2 5 3
15 |Organisation C 21/12/2013 2 4 2
15 |Organisation C 21/02/2014 2 5 3
17 |Organisation D 21/01/2014 2 3 1
18 |Organisation E 21/09/2013 2 1 -1

11
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c. Alternatively you can employ an automated traffic light Colour Scale!

H ©- = Excel for ME&E training workbook students - Excel

FILE HOME | INSERT ~ PAGELAYOUT  FORMULAS ~ DATA  REVIEW  VIEW

o ¥ Cut .. = = - = D:'x B 3 Aut

alibri - - == - ra enera - - ? grm o
Paste B COPY - G _ i _ o o o o c° \F’;‘t ol IEEIrt [‘JEEI'et Flllt W Fr-
¢ omatpaier BI T W7 DA === e EMegeacener - -0 0 o3 Condlansl formater O Insert Delte Format
Clipboard ] Font [Fl Alignment [Fl Number ] ﬂigh\ight(ells les Cells
E1 - j1 Progress made =
A B c D E F G H Top/Bottom ' L M

1 |Organisation name Date Initial 1t Final 1t Progress made

2 |Organisation A 21/09/2013 1 3 2 E Data Bars v

3 |Organisation A 21/09/2013 2 2 0

4 |Organisation v 21/09/2013 1 3 2 [:] Color Sca , % % E %

5 |Organisation A 21/10/2013 2 3 1 _ _

6 |Organisation A 21/11/2013 1 2 1 E Icon Sets N ﬁ % ﬁ %

7 |Organisation A 21/12/2013 1 4 _ _

& |Organisation A 21/01/2014 1 a4 B NewRule.. e EE==! = 5

9 |Organisation | 21/02/2014 1 4 E? Clear Rules v
10 |Organisation A 21/02/2014 1 3 2 [ Manage fules More Rules...
11 |Organisation A 21/02/2014 1 3 2 I
12 | Organisation A 21/03/2014 1 3 2
13 |Organisation B 21/11/2013 2 a4 2
14 |Organisation B 21/01/2014 2 s

17) Validating data entry - Excel also allows you to pre-set criteria with which to validate
cell entries.
a. This enables you to ensure consistency & standardisation — particularly useful if a
number of people are entering data.
b. Go to the Data tab and select Data validation
[= I < Excel for MALE training workbaok™Excel
FILE HOME ~ INSERT ~ PAGELAVOUT  FORMULAS = DATA  REVIEW  VIEW

Ij% I:%) I:'El IE D ||=9 [=] Connections 8] Y Clear E’E F E_)g S/@ E"E‘ ,g_—\?

Properties Reapply
From From From From Other Existing Refresh _‘ . "Lc"l Sort Filter o Textto Flash Remove Data Consolidate  What-If Relatic
Access Web Tedt Sources-  Connections Al - Edit Links YoAdvanced  Columns  Fill  Duplicates Validation ~ Analysis -
Get External Data Connections Sort & Filter Data Tools
Data Validati
P31 e fe || Selena ot Taligation
Pick from a list of rules to limit the
B C G H K L M N Q type of data that can be entered in a
31|mireide  williams  SM27PY Inactive P
32 |Serena Gonzales SM3 IHN Waiting list S€l For example, you can provide a list
33|pat Bonnington SM4 6PW Current 2 Sel of values, likel, 2, and 3, oronly
34 |pat Rawlings SM27WJ Current 5 Sel allow numbers greater than 1000 as
~  wvalid entries.
351Petra Simmons  SM44PE Waitine list Sel

c. There are a number of criteria you can choose from and you can even put in

your own input message to guide | oatz vaidation (2 wes /
explain to others what's required Settings | Input Message | Error Alert | as
Validation criteria
well as your own error message. Allow:
Any value u Ignore blank

Apply these changes to all other cells with the same settings

o ] [one

12



Superhighways training, June 2021

d. If you have a set list of options you want people to select from (and not enter

anything else) e.g. ethnicity categories, then choose the List option.

Data Validation @

Settings Input Message | Error Alert |

Validation criteria
Allow:
List E| [¥] 1gnore blank
. In-cell dropdown
Data
between
Source:
='13"15C51:5C54 Rz

Apply these changes to all other cells with the same settings

o] [mai )

e. It will now ask you to indicate where this List can be found by selecting the cell
range in the Source, as above. Navigate to where you have previously entered
list options and highlight - it is a good idea to dedicate a separate Worksheet to

your look up lists

18) Summary sheets / dashboards — linking sheets - these take data from other Work-
sheets to feed into summary reports to help with monitoring
a. Open a new Worksheet and rename
b. Add the parameters you need 1o track and then in the formula expression, ‘bring
in’ data from the other Worksheets by selecting cells / ranges as appropriate.
You will notice in the formula box that this is indicated by a  “Worksheet name’!

the cell reference or range

e.g. =COUNTIF( 'Training stats'lE2:E50, Training summary'lA31)
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19) Quick analysis — this is a handy short cut option in Excel 2013

a. Click any cell in your data and then click Cirl & Asterisk (the Ctrl key, Shift key

and number 8 key)

Quick Analysis (Ctrl+Q)
Use the Quick Analysis tool to

quickly and easily analyze your data
with some of Excel's most useful
tools, such as charts, color-coding,

and formulas.

@ i [A] ~

b. Clicking on the Quick Analysis icon then brings up a range of options as below:

Formatting option

CHARTS TOTALS TABLES SPARKLINES -

Data Bars Color.. Icon5et Greater.. Topl0%  Clear.

Conditional Formatting uses rules to highlight interesting data. -

Charts option

FORMATTIMG CHARTS TOTALS TABLES SPARKLIMES |

TN i

Clustere... Clustere... Line More...

Recommended Charts help you visualize data. i

0]

[v]

[+]

14
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Tables option — here there is a short cut to Pivot Tables

les 1

TOTALS

e

FORMATTING

B @

Table

CHARTS

e

Tables help you sort, filter, and summarize data.

TABLES

[

PivotTable PivotTable PivotTable PivotTable

i

More

SPARKLINES

20) Pivot tables Quick Analysis gives you a number of pre-defined Pivot table options,

selected as the best fit for the data in your worksheet

a. . Hover over the options and select the one that fits your needs (you can make

changes later)

L
2
- .
3 Row Labels| =  Count of Family number
4 |Current 20
5 |Inactive 13
6 |waiting list 16)
| ]
7 Grand Total 49
8
9
b. You can also create a Pivot table by selecting the worksheet area and then
going to the Insert tab and selecting Recommended Pivot Tables
x| Taiming workbook students - Excel 2@ - i
FILE HOME | INSERT = PAGELAYOUT _ FO) REVIEW ~ VIEW Kate White
0D e = i-=-%- s O e e B R G B QA T
i iy lag 2 sen A |- A i P S i
PivatTable Recommended Table  Pictures Online M My Apps - E Recommended . PivatChart  Power  Line Column Win/  Slicer Timeline Hyperlink Text Header
PivotTables Pictures @+~ Chats ™ Lo~ View Box & Footer
Tables Tlustrations Apps Charts fa Reports Sparklines Filters Links Text Symbols
150 ;M )‘\ Unallocated
A B C D E F G H 1 J K L M N [s] P
1 |Family number Firstname Surname Address line 1 Address line 2 Town Post code Status No. of children Child1dob Child1age Whichvolunteer
2 12 Alison Stanley SM11BA Inactive 1 28/11/2010 4 Karen
3 9 Becky MacRae SM11AX Current Helen
4 2 Chris. Evans SM11AD Current Jane
5 5 Christine Scott SM13NQ Waiting list Unallocated
6 10 Claire Smith SM11AY Waiting list Unallocated
7 33 Clare Woodhouse SM49A)  Current Jane
8 42 Daniella  Collins SM25TQ. Current Jane
9 49 Dominique  Foster SMA4PE  Waiting list Unallocated
10 8 Donna Turner SM1 1AW Current John
11 18 Healah Siddig SM11BN Current Jane
12 24 Jackie Godowska SM3 8BQ. Waiting list Unallocated

15



Superhighways training, June 2021

c. Again you will be presented with a choice of Pivot Tables

-

Recommended PivotTables

@&1

Count of Family number... =+

Count of Family number by Status

Row Labels = Count of Family number

Current a0 Current

nastive i3 Inactive

‘Waiting list 16 . .

Gramd Total 19 Waiting list
Grand Total

Count of Family number ...

Ao Labels - Cownt of Family namber

Halan 1
Jane
Fain

Bwn

Karen
Selena
Simons
unaliocated
Gramd Tetal

&=
B0 o ow

Count of Family number ...

B Labels

= Currank
Allisen
Boed
Barearghon
Bams
ol
cragan
Croxtad

.......

= Count of Family numbar
3

Count of Family number ...

R Lalbeds = Caiint of Family numbar

= Curent n sl

Row Labels v |Count of Family number

20
13
16
49

Blank PivotTable Change Source Data...

[ ok

| o)

Row Labels
=1

-4

Grand Total

Finally - you can also start from scratch by opting to inset a Blank PivotTable

The Pivot table side bar is where you can now ‘drag and drop’ fields around to

control the data analysis as you need

f. First check the fields you want displayed — here we’ve added the Date field and

it is automatically added as a row.

v | Count of Organisation name

21/09/2013
21/11/2013
21/12/2013
21/01/2014
21/02/2014
21/03/2014

21/09/2013
21/10/2013
21/11/2013
21,/12/2013
21/01/2014
21/02/2014
21/03/2014
(blank)

mhwmwl—ibgwwhlmmiﬂg

21/09/2013
21,/01/2014
21/02/2014

il = L]

21,/02/2014
49

X

PivotTable Fields
Choose fields to add to report: -

+| Organisation name

+/| Date

+/| Initial assessment
Final assessrnent
Progress made

MORE TABLES...

Drag fields between areas below:

FILTERS COLUMNS

ROWS % VALUES
Initial assess.. ¥ Count of Org... ¥
Date &2

16
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g. Now you can drag the Date field to the Columns quadrant

Drag fields between areas below:

T FILTERS I coLu

Date o
= ROWS Z VALUES
Initial assess... ™ Count of Org... *

h. This will automatically update the table as below, now displaying dates across as

columns

Count of Organisation name Column Labels -

Row Labels ~ 21/09/2013 21/10/2013 21/11/2013 21/12/2013 21/01/2014 21/02/2014 21/03/2014 (blank) Grand Total
1 5 2 6 1 3 3 20
2 4 1 3 3 3 4 2 20
3 6 1 1 8
4 1 1
Grand Total 15 1 5 9 5 9 5 49

i. To analyse data further, now select Pivot Table Tools and the Analyze tab.

H - ¢&- - / PIVOTTABLE TOOLS
FILE HOME INSERT PAGE LAYOUT FORMULAS DATA REVIEW VIEW AMALYZE DESIGM
PivotTable Name:  Active Field: —= =2 Group Selection — =
3| 3 o 5 B
PivotTable3 Date ) ) g Ungroup i =
- - - Drill  Drill == ] Insert  Insert Filter Refresh Change Dat
[ Options ~ [ Field Settings Down Up B Group Field Slicer Timeline Connections - Source -
PivotTable Active Field Group Filter Data

j. This gives you a range of tools to help you further customise your Pivot Table e.g.

Group fields. In this example we can group dates by Months and / or Quarters.

A B d Grouping 7 = |k H I
1 Auto
2
. Starting at: | 21/09/2013
3 Row Labels ~ | Sum of Final assessment s .
4 | =Organisation A 27 Ending at: | 22/03/2014
5 21/09/2013 5 By
5] 21/10/2013 3 Seconds =
Minutes
7 21/11/2013 2 Hours
8 21/12/2013 4 Dais
9 21/01/2014 a Quarters
10 21/02/2014 & Years
11 21/03/2014 3
12 = Organisation B 9 MNumber of days: |1
13 21/11/2013 4 oK l [ Cancel
ance
14 21/01/2014 5
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Row Labels | = | Count of Organisation name
=1 20
=qtrl
Jan
Feb
Mar
=Qtr3
Sep 5
=Qtrd
MNov 2
Dec 7}

21) Pivot charts

a. You can also create a PivotChart from the Insert tab

T EH - x
Kate White ~

[7. Fields, Items, & Sets~ I E? E EllE‘ E

fx OLAP Tools
) PivotChart Recommended Field +/- Field

Relationships PivotTables List Buttons Headers
Calculations Tools Show s
PivotChart v
Insert a PivotChart tied to the data
L M M in this PivotTable,
1 — e _ 1 I _ -
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Row Labels |Z| Count of Family number Count of Family number

Current 20
Inactive 13 Total
Waiting list 16 75
Grand Total 49
20
15
10 m Total
5
0
Current Inactive Waiting list
Status «
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