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Excel Next Steps 2 – Session Exercises

Topic 1 

Part 1 – Splitting Columns Using a Delimeter

* Tip: When inserting a column, first highlight the column to the right of where you want it to be and right click – select Insert. 

In the Counselling Service sheet

1. Put the Counselling Service data into a table 
(Go to the Insert tab, Table group, and click on the Table command. Check the cell range is correct and the ‘My data has headers’ box is ticked and click OK)

2. Name your Table ‘Counselling’ 
(In the Table Design Tab, Properties group, overtype ‘Table1’ under Table Name)

3. Split the Name column into First Name & Surname using a Delimiter 
(First insert a new column to the right of the Name column by highlighting the Date of Birth column, right click and select Insert. Then highlight the column you want to split, go to your Data tab, Data Tools group and select the Text to Columns command. In the wizard - select Delimited, Next, Space, Next and Finish. Because our data is in a Table, Excel will have automatically created a header for your newly inserted column and so a pop-up box will say ‘There’s already data here. Do you want to replace it?’ Click OK)

4. Rename your column headers to be First Name and Surname

5. Rejoin these columns using the CONCAT formula, so that you also have a column for Full Name


(Insert a new column to the left of the Date of Birth column. Enter = followed by CONCAT in the first cell of the new column (under the header row) then select the open bracket (shift 9) and then select the cells you want to join together separated by ," ", to add a space in between the 2 parts and then close bracket (shift 0) 
=CONCAT([@name]," ", [@Surname]) 

6. Rename your column header Full Name

You now have the option to re-paste this column data as ‘values’ rather than leaving the formula in the column which can sometimes cause problems. To do this – click on the top cell of data in the column – Malorie Blackman – and select the whole column of data using Ctrl and the Space key. Then select Ctrl + C on your keyboard to copy the data (or Right Click and Copy). Then Right Click and under Paste Options select ‘Paste as Values’.


Part 2 – Splitting Columns Using a Fixed Width

* Tip: Click on Ctrl and the Space bar when in the first row of data to select the rest of the column

7. Split the Referral ID # column using the Fixed Width option, keeping the existing Referral ID # column as it is for future use.
(Insert 2 new columns to the right of the Referral ID # column. Copy the content of the Referral ID column into the adjacent column – click into the top cell of data and use Ctrl and the Space bar on your keyboard to select all the cells of data in the column. Ctrl C to copy the data. Then select the top cell under the column header in the adjacent column and press Ctrl V to paste the data. 

8. Now select the new column of data (by clicking on the column header – Column D). Then select the Data Tab and the Text to Columns command. Choose the Fixed Width option and select Next. Drag the line in the Data preview so that it shows between the AS and the number and click Next. The Data preview will now show AS highlighted in white text on a black background. Click Finish and OK when the warning message pops up that there is already data here)

9. Rename your new column headers ‘Referred From’ (AS) and ‘Referral #’ 



Topic 2 

Part 1 - Data Validation using a Date Format

* Tip: Click on Ctrl and the Space bar when in the first row of data to select the rest of the column

In the Counselling Service Sheet

10. Add a Data Validation using the Date criteria to the Referral Date column. 
(Click in the first cell of data in the Referral Date column, press Ctrl and Space bar to select all the cells of data in that column. Go to the Data tab, select Data Validation in the Data Tools group. In the Settings tab of the Data Validation Box, select Date from the ‘Allow:’ dropdown list and choose Between from the ‘Data’ options. Enter a Start date of 01/04/2023 and End date of 31/03/2024 and click OK)

11. There is a cell with an error in the date. Correct the date to be 2023.

12. Now add an Error Alert message 
(Click in the first cell of data in the Date Referred column, press Ctrl and Space bar to select all the cells of data in that column. Go to the Data tab, and Data Validation command in the Data Tools group. In the Error Alert tab, type in a message, so that when a date that does not meet the criteria for this dataset is entered, the person will immediately understand why and can re-enter a date or investigate the issue with the date they have)



Part 2 - Data Validation using a List

13. Create a Data Validation List for the Ethnicity column 
(Select the blank cells in the Ethnicity column (Ctrl + Space) Go to the Data Tools group and select Data Validation. Check you are in the Settings tab of the Data Validation box and choose ‘List’ from the ‘Allow’ dropdown & click on the thick black vertical arrow (the Collapse button) at the right-hand side of the Source box to enable you to navigate to your Validation Lists sheet and select the Ethnicity column header (Column A), press Enter on your keyboard or click on the blue downwards Arrow icon (the Expand button) to take you back into the Data Validation dialogue box, and click on OK) If you now click in any of the cells in the Ethnicity column – you will see a little drop-down arrow has appeared at the right hand edge of the cell from which you can choose an ethnicity.

14. Add ‘Was not asked’ to the bottom of the list of Ethnicities in your Validation Lists sheet. Check that this updates your pick-list options, by clicking on the arrow showing at the right-hand side of cells in the Ethnicity column on your Counselling Service sheet.

15. Add an Error message explaining that you need to select one of the options from the list (Select the data in the Ethnicity column. Then go to the Data tab, and Data Validation command in the Data Tools group. In the Error Alert tab of the Data Validation dialogue box, type in a message explaining that you need to select an option from the existing list) 

16. Now type in an Ethnicity with a spelling error to check that the error message works.
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*Tip: If you can’t see your PivotTable Fields or PivotTable Analyse or Design tabs when working with PivotTables, make sure you have clicked somewhere in your PivotTable to bring back those options. This is your PivotTable.

Part 1 – Creating Pivot Tables

In the Counselling Service sheet 

17. Create a PivotTable to show the number of clients attending each Counselling Service by quarter
(On the Insert tab, select the PivotTable command, and choose to place the PivotTable in a New Worksheet – this will then open in a sheet to the left of your Counselling Service sheet) 

18. Rename the new sheet – PIVOT Clients by Quarter (Right click on the sheet tab, select Rename and then overtype the existing selected sheet name)

19. Click anywhere in your PivotTable and rename the PivotTable ‘Client_Numbers’ (Go to the PivotTable Analyse tab and in the PivotTable group, rename the PivotTable - See *Tip above if you can’t see your PivotTable Analyse Tab) 

20. In the PivotTable Fields list on the far-right of your screen (these equate to your column headers in the Counselling Service Table) select Counselling Service, Full Name and Referral Date. When fields are selected, by default they drop into the Rows Quadrant (bottom left quadrant). 

21. Drag and drop ‘Full Name’ into the Values Quadrant – to see Count of Full Name. 

22. Note the different Date options that have become available to you in the Rows Quadrant. Drag and drop ‘Quarters (Referral Date)’ into the Columns Quadrant and then drag and drop Years, Months and Referral Date back up into the PivotTable Fields List.  

23. Format your PivotTable
(e.g. Make the column widths the same size, centre the cell contents, make the font bigger – using commands on the Home tab, and change the PivotTable Style in the Design tab.)

24. In case we have any clients with the same name, we need to find a unique identifier in our dataset. Switch the Count of Full Name field (in the Values Quadrant) for Referral ID #
(Click the arrow to the right of the Count of Full Name field and select Remove Field. Drag and drop Referral ID into the Values Quadrant and reformat your PivotTable)

25. From the Counselling Service sheet - Insert a PivotTable into a new worksheet. (Insert tab, PivotTable command) 

26. Rename the new worksheet PIVOT Advice Outcome

27.  Click in your PivotTable and rename it ‘Advice_Outcome’ (See PivotTable group in the PivotTable Analyse tab and overtype the default name)

28. Set up your PivotTable to show the outcome of the advice issues our clients have been facing that has led them to be referred for counselling at our different Counselling Services
(Click and drag Referral ID # from the PivotTable Fields list into the Values quadrant. Select the Counselling Service checkbox and the Advice Issues Resolved checkbox so that they automatically drop into the Rows quadrant. Move the Advice Issues Resolved field into the Columns Quadrant.)

29. If the Referral # is showing as Sum of Referral #, click on the arrow to the right of this field and select Value Field Settings. In the Summarise Values By tab, select Count and click OK.




Part 2 – Changing the Value Field Settings

30. Now in the Values quadrant, change the Value Field Settings to show as % of Row Total (Click on the down arrow next to ‘Count of Referral #’ and in the ‘Show Values As’ tab, choose % of Row Total.)

31. [image: ]Remove the decimal places and centre align your values
(Highlight the cells with % in them in your PivotTable, go to the Home Tab, Number Group, and select the Decrease Decimal command to remove decimal places (using the   command) and go to the Alignment group in the Home Tab to change the alignment.)

Topic 4 – Summary Sheets

Using the Summary Sheet 

32. Add our Counselling Service client numbers into the Summary Sheet. Create a Get Pivot Data formula in the top cell of the Number of Clients column (for the Lambeth Counselling Service) by clicking in the cell and entering =

33. Then move to the PIVOT Clients by Quarter Sheet (see Sheet tabs at the bottom) and click on the cell with the Grand Total results for Lambeth and press Enter.

34. Now copy the formula down to the Lewisham cell and click into the Number of Clients cell in the Lewisham row and look at the Formula Bar. In the formula bar look for the word Lambeth and overtype it with Lewisham. The number in the cell will change.

35. Drag that formula down again into the Southwark row of data and again look at the Formula Bar. This time in the formula bar, select the whole text of “Lewisham” (including the speech marks “ ”) and click on the word Southwark in cell A6 – so that A6 becomes referenced in the formula. Press Enter on your keyboard.

36. Now drag the formula down and note that the cell reference changes and automatically updates the data for Wandsworth.

Additional exercise

Repeat the exercises in Topic 4 but for the % Clients whose advice issues were Partially Resolved or Unresolved.  

· In the top cell in the % of clients whose advice issues were partially resolved or unresolved column (for the Lambeth Counselling Service) enter = 
· Then move to the PIVOT Advice Outcome Sheet (see Sheet tabs at the bottom) and click on the cell showing the Partially Resolved percentage for Lambeth and then in the formula bar type + and then select the Unresolved percentage for Lambeth and select Enter on your keyboard.
· Now copy the formula down to the row for Lewisham data. Click the drop down arrow at the far right of the formula bar so you can see the whole scary formula! Now look for the word “Lambeth” – select the whole word including the speech marks, and then click on cell A5 which shows the word Lewisham. You will need to repeat this again for the second time that “Lambeth” appears in the formula. 
· Drag this formula down into the Southwark and Wandsworth rows of data and note that the cell reference changes and automatically updates the percentages.
· Double check the numbers are correct by looking at your PIVOT Advice Outcome sheet.
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