
1 

 

 

 

 

Excel Essentials 
 

Course Handbook  
 
 

 

Contents 
 

1 

Working with Excel     2 

Viewing Spreadsheets    4 

Sorting your data     8 

Using Formula     10 

Splitting columns     12 

Printing      13 

Managing data with tables   14 

Filtering      18 

Charts & graphs     22 

 

  



2 

 

 

Working with Excel 

1. Understanding the Ribbon 

It really helps to get to grips with the Excel terminology as it makes like a lot easier to find things & 

understand instructions when using the Microsoft Excel help feature or the internet for help. 
 

 
The Ribbon is made up of five basic components: the Quick Access Toolbar, tabs, groups, command buttons, 

and dialog launchers. 

• The Quick Access Toolbar is essentially a customisable toolbar to which you can add commands that 
you use most frequently. 

• Tabs contain groups of commands that are loosely related to core tasks. It helps to think of each tab as 
a category. 

• Groups contain sets of commands that fall under the umbrella of that tab’s core task. Each group 
contains buttons, which you click to activate the command you want to use. 

• Dialog launchers are activated by clicking the small arrow located in the lower-right corner of certain 
groups. Clicking any dialog launcher activates a dialog box containing all the commands available for a 
given group. 

• Command buttons when clicked launch a macro which perform a specified action in Excel. 

 

2. Getting help 

If you can’t remember where to find a function in Excel, use the search function at the top to get assistance. 

http://www.google.co.uk/url?sa=i&rct=j&q&esrc=s&source=imgres&cd&cad=rja&uact=8&ved=2ahUKEwjb8ObS87fnAhVCQhoKHSchA80QjRx6BAgBEAQ&url=http%3A%2F%2Fwww.informit.com%2Farticles%2Farticle.aspx%3Fp%3D2067634&psig=AOvVaw2C9kVlXoJORUM3kmstdKTm&ust=1580905926307341
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3. Correcting mistakes 

Microsoft Excel tracks all the changes you make to a file, if you make a mistake (or two!) you can step 

yourself backwards through the changes you made to reverse anything you did wrong. 
 

 

 

4. Different Versions of Excel 

There are several different versions of Microsoft Excel, be aware that different versions offer different 

features and existing features might be accessed via different means. 

These different versions & how they look on a laptop versus a PC means that the screen prints in this 

document might not always look exactly the same as the screen in front of you. But the features will be 

there so look for the icons which remain consistent or use the search feature to find them. 

Microsoft 365 

The Business Premium Licence is donated (10 licences per registered charity) and comes with the Microsoft 

office suite, including Excel, to download. 

Microsoft Office 2016 & later 

Previously you could buy a discounted licence if you are a registered charity from Charity Digital for £33 for 

Microsoft Office 2019. These products are no longer available, you would need to pay full price for a local 

standalone desk top option. 

Microsoft licencing is often included on a 2 year open licence which means you get upgrades during this 

period, so if using an older version, check before buying anything in case you are eligible for an upgrade 

rather than paying for a new product. 

 

 
1.Click on Undo 

arrow to go back a 

step. You can 

continue to step 

back multiple times. 
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Viewing Spreadsheets 
Working with workbooks with large amount of data in each sheet can be very unwieldly. Before starting it’s 

worth getting your view sorted out so that you can easily move around between worksheets. 

5. Format tabs 
 

 

6. Freeze panes 
Allows you to control areas of the spreadsheet to be fixed as you scroll. 

Unfreeze panes 
 

 

 
1.Right click on the sheet tab to reveal 

formatting options: Rename, Move & Tab colour 

1.Click on the View tab 

2.Click on the arrow on 
the freeze panes 

command 

button 

3. Select how you want 

to freeze panes 

 
 
 
 

Click on the View tab 
 
 

Click on the arrow on 

the freeze panes 

command button 

 
 

Select Unfreeze 

panes 
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7. Hide columns 

Hiding columns from view can be very useful when working with big spreadsheets so that you only work with 

the columns you need. 

 

8. Unhide Columns 

 
 
 
 
 

 
Highlight the column you want to 

hide by clicking on the letter at the top 

of the column 

 
 
 
 
 

 
Right click with your 

mouse and select Hide 



6 

 

 

 
9. Resize columns 

 

 
 
 
 
 
 

 
1. Select the columns you 

want to resize 

 

 

2. Hover with the mouse 

between columns. When 

the mouse pointer changes 

drag the column to the 

width you want or double 

click for it to automatically 

resize. 

 
 
 

 
1. Highlight the columns on either side 

of the hidden column by clicking and 

dragging across the top of the 

columns. 

 
 
 
 
 
 
 
 
 
 
 

 
2. Right mouse click and 

select Unhide 
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10. Wrap text 

Wrap text allows you to display a long line of text on multiple lines so that it can all fit in one cell. 
 

2. Click on Wrap Text 

1. Select the cell where you 

want to wrap the text 
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Sorting your data 

11. Sorting (Single level) 

Simple sorting can be done by highlighting the column you want to reorder and using the options available in 
each column header. 

 

 
A Sort Warning dialogue box should pop up, checking that you want to reorder the rows in full, rather than 
just that column in isolation. 

 

 

12. Quick Count view 

 

 
Select a range of cells and quickly 

view a Count of the number at 

the bottom right of your screen 

Highlight the column 

you’d like to reorder. 

2. Select Sort A-Z or Z-A 
depending on your desired 

order. 

 
 

 
Keep the Expand the 

selection selected and 

click Sort. 
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13. Sorting (Multi-level) 

More complex sorting options are available via the Home tab 

 

 

 
 
 
 
 
 
 

 

4. Click on + Add level to add a secondary sort level. For example, 

here we are sorting by prison name and then by participant name. 

Take a moment to think through the logical order you are sorting on. 

1.  Click on the Sort option 

2. This window will open. Select the column you want 
to Sort by, the value to sort by and the sort order for 

the first level of sorting. 

 
 
 
 
 
 

 
3. If you only see Column A, 

Column B etc in this list, click 

My data has headers 
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Using Formula 

14. Auto sum 

Automatically add up a range of values to arrive at the Total. 
 

 

 

15. Copying formula 

Once a formula has been entered into a cell, instead of recreating this formula in a neighbouring cell, you 

can ‘copy’ this formula to other cells so the equivalent calculation is made. 
 

1. Click in the cell you want the Total to appear in (in this case I2) 

and then select the AutoSum icon in the Home tab menu. 

Check that the correct range of cells has been highlighted (in this 
case C2:H2). You can extend this range by clicking on the corner 

of the highlighted section and dragging to include more cells. 

 
 
 
 
 
 
 
 
 

 
Click on the cell containing the formula you’d like to copy. Hover 

over the bottom right corner of the cell where you see the solid 

square, until the cursor changes to a plus sign. Now click and drag 

down to copy the formula to cells below. Let go and the Total 

values will appear in these cells. 
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16. Average 

Similar to AutoSum, the Average function will automatically calculate the average for a range of values. 
 

 

 

17. Adding a simple multiplication 

When adding a formula to calculate a multiplication, first enter the = equals sign. Then instead of typing in 

the values, select the cell containing the first value; add the * sign (Shift key and number 8 key), and then 

select the cell containing the second value. Then click Enter. 
 

 
 
 
 
 

 
Alternatively, you can select the cell containing the 

formula and the neighbouring cells you’d like to copy 

it too and then click on the Fill icon in the Home menu 

and select the relevant direction. In this case Down. 

 
 
 
 
 
 
 

 
As with AutoSum, select the cell where you want the 

Average value to be calculated and then click on the 

down arrow next to the Auto Sum icon and select 

Average. 
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Splitting columns  
 

Often there is a need to break down data to make it easier to work with. For example, if you want to sort 
people in alphabetical order using their surname you will need to make sure their name is split into first 
name & surname columns. 
 
Tip: It’s a good idea to first create a column to the right of the column you wish to split, for the second 
part of the column contents to move into. 
 
 
*space before a name so that count if doesn’t work -bring it back as an exercise in the formulas. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
(A Delimiter is a blank space, comma, or other character or symbol that indicates the beginning or end of a 
character string, word, or data item) 
 
 
 
 
 
 
 
 
 
 

1. Click on the 
Data tab  

2. Highlight the 
column to split  

3. Click on the Text 
to Columns 
command button 

4. The Convert Text to 
Columns wizard will open  

5. Select Delimited & then 
click on Next  

6. Select what delimiter to use to 
separate the data into columns. In this 
example the data to split is separated 
by a space 

7. The wizard displays how 
the text will be split 
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Joining columns 
Sometimes you may want to join (or rejoin) columns. The formula to do this is called Concat. Create a new column 
and in the first row add the formula below: 
=CONCAT(select cell 1," ", select cell 2) and then copy the formula down to rows beneath. 
 

Printing 
 

In the print preview screen you can review your data before printing it. 
 

 

 
 
 
 
 

 
Make sure the orientation is 

correct for the data set 

 
Scaling allows you to neatly fit 

all columns and / or rows on 

one page 

 

 
Select Page Set Up to add 

headers and footers to pages 

8. Select the data format for each 
column. General automatically 
converts the column to the most 
appropriate format. You can 
override that now or later after 
the split 
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Managing data with tables 
 

The advantages of an Excel table include all of the following: 
 
1) Quick Styles 

Add colour, banded rows, and header styles with just one click to style your data. 

2) Table Names 

Give a table a name to make it easier to reference in other formulas.  

3) Cleaner Formulas 

Excel Formulas are much easier to read and write when working in tables. 

4) Auto Expand 

Add a new row or column to your data, and the Excel table automatically updates to include the new 

cells. 

5) Filters & Subtotals 

Automatically add filter buttons and subtotals that adapt as you filter your data. 

6) Dynamic Pivot tables  

If you use an Excel Table for the source data of your pivot table, the data range becomes "dynamic". 

A dynamic range will automatically expand and shrink the table as you add or remove data, so won't 

have to worry that the pivot table is missing the latest data. When you use a Table for your pivot 

table, the pivot table will always be in sync with your data. 

 
 
 
 
 
 

 
Select Header/Footer to add 

in automatic or custom 

headers and footers 



15 

 

 

 

Make your data into a table 
 

 

 
 

Naming the table 
 
It is good practice to name the table as it makes life much easier later when working with formulas. Naming 
the formula is basically giving your data set a name which will enable you to recognise which data set you need 
to be working with. 
 

 
 
 

Formatting the table 
There are a number of table formatting options in Excel. The benefit of the table format is that it ensures each 
new column or row you add to your table will be automatically formatted in the same way. 

1. Click on the 
Insert tab  

2. Click on the 
Table command 

button  

3.  A window will open. 
Confirm the cells to be 

included in the table and that 
the data has headers 

1. Click on the table & select 
the Design tab 

2. Rename the table. For 
example, “Participants” 
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Adding a Total column 
 

  

 

Adding a Row Total 

Change the look and feel of 
your table with the formatting 
tools 

2. On the Table Design tab, 
check the box Total Row  

1. Highlight the columns you 
want totalled 
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Filtering 
 
Filtering (Select & Deselect) 
 

 
  

1. Click on the arrow next to the column 
header of the column you want to filter by 
 
 

2. Select the values you want to filter by 
 
 

When you have applied the filter, look at the bottom of the 
sheet to see the total count of the filtered rows. 
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Filtering (Text filters) 
Excel has more advanced filtering options available via text filters: 

 

 
 
 
 

3. A Custom AutoFilter 
window will open. 
 
 

4. Check the 
filter type 
correct 
 
 

5. Enter the value 
you want to filter by 
 
 

1. Click on the arrow next to 
the column header of the 
column you want to filter by 
 

2. Select Text Filters 
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Data Slicers 
Slicers are visual filters. Using a slicer, you can filter your data (or pivot table or pivot chart) by clicking on the 
type of data you want. 

 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

1. Click on the 
Insert tab 
 
 

2. Click on 
Slicer 
 
 
 
 
 

1. Insert Slicer 
window will open. 
 

2. Select the 
column(s) you would 
like to use for 
filtering 
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4. Select a single filter 
option to apply the filter 

5. To add more than one 
filter click on the Multi-
Select button  

6. Select multiple filter 
options to apply  

3. Drag and drop the slicer to 
the location you want 
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Charts & graphs 
 

First highlight the data you want to visualise and then go to the Insert tab and select Recommended Charts 
 

 
 

Select one of the Charts and click OK. Alternatively select All Charts and then choose one of the many types to suit 
your needs. 
 

  
 
 

The Chart will then be added to your Worksheet. You can move it around to a position of your choosing and can 
also drag the corner to resize. 
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Click on the Chart and you should see a Plus, usually at the top right. Click on this to view options you can 
customize e.g. Axes values and titles, Data labels, Legend and show / hide Gridlines.  
Hover over these options to see aright arrow indicating other choices – sometimes with a More options… 
so just explore to see what’s possible in terms of customising your visual. 
 

 
 

Similarly – clicking on the Paintbrush brings up choices relating to colour and design and the funnel icon 
enables you to filter the data. In the above example I could choose to only show Jan – June rather than the 
full year. 


