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Session 1 – Managing data with tables
[bookmark: _Toc219282723]Exercise 1: Creating tables 
1. Click anywhere on the data in a sheet
2. On the Insert menu, click on Table
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3. Make sure the whole table is selected by checking the cell range and option My data has headers is ticked.
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4. From the Table Design tab, select the Table style you want to change the look & feel
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The colours options come from your theme, if you want to change the colours you will need to go to Page Layout tab, select the theme you want and amend the colours on it.

Adding formulas with Flash Fill
1. Add a formula in the first cell of the column where you want the formula. Flash fill should add the formula to the whole column. If it doesn’t, drag the formula down a few cells and then right- mouse click and select Flash fill to have the formula populate all the way down
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Data validation
Data validation in Excel is a feature that lets you control what kind of data can be entered into a cell or range of cells.

[bookmark: _Toc219282724]Exercise 2: Data validation - List

1. Click into the first cell of the column where you want to apply data validation
[image: A screenshot of a computer
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2. In the Allow field select List. Click into the Source field and then go to the Validation lists sheet, highlight the ethnicity list and click on enter on your keyboard. The worksheet and cell range will then appear in the Source field.

[image: ]


3. Add an Error Alert to stop people entering anything which is not on the validation list. In the Style field, select Stop and then in the Title explain why they cannot enter data.
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[bookmark: _Toc219282725]Extra exercise: Data validation - type
1. Click into the first cell of the column where you want to apply data validation
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2. In the Allow field select Date, in the Data field select greater than in the Start date put in the earliest possible date e.g. 1/1/1925 as anything earlier would mean someone over 100 being in the prison.  
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3. Add an alert to warn them what data is required. This will not stop data entry but just warn when it is entered incorrectly. Change the style to warning, put in a title and give an error message to help users understand what the correct data should be.
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Conditional formatting 
Conditional formatting in Excel lets you automatically change how cells look—like colors, icons, or data bars - based on their values, so patterns and important info stand out instantly.

[bookmark: _Toc219282726]Exercise 3: Conditional formatting – Directional
1. Select the Change in Optimism column but clicking in the column header
2. On the Home tab, click on the Conditional formatting button and then Icon sets to pick a directional arrow.
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Tip: You can use Icons to sort and filter your table.
[image: ]


[bookmark: _Toc219282727]Exercise 4: Conditional formatting – Duplicates
1. Select the Name column but clicking in the column header
2. On the Home tab, click on the Conditional formatting button, Select Highlight Cells Rules and then Duplicate values
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[bookmark: _Toc219282728]Exercise 5: Adding totals
Adding a total row
1. Click anywhere on the table to select it
2. On the Table Design tab, tick the Total row box
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Selecting a type of total
1. Click in the total row in the column where you want to add a calculation and select it off the list



[bookmark: _Toc219282729]Session 2: Pivot Tables, Charts and Summary Sheets
Pivot tables are a feature in Excel and Power BI that lets you summarise, explore, and analyse large datasets quickly and interactively — without writing formulas from scratch.

[bookmark: _Toc219282730]Exercise 1: Creating Pivot Tables
1. Using the All participants sheet, insert a Pivot table (Insert tab and select the PivotTable) 
2. Name the Pivot Table ‘Enjoyment’ (see top left of PivotTable Analyse Tab, or click down arrow under PivotTable Command)
3. Select the following fields in the PivotTable Fields list on the far-right of your screen: Prison, Prison number, Enjoyed the sessions (If you don’t see these options, make sure you have clicked somewhere in the PivotTable on the left)
4. Drag ‘Enjoyed the sessions’ to Columns; drag ‘Prison number to Values; keep ‘Prison’ to Rows. Check the Values is showing as ‘Count of Prison number’.  
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5. Now change the Value Field Settings to show as % of Row Total (Click on the down arrow next to ‘Prison ID’ in the Values quadrant and choose % of Row Total from the ‘Show Values As’ tab)
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6. Remove the decimal places (Highlight the cells with % in them in the PivotTable, go to the Home Tab, Number Group, and select the Decrease Decimal command twice to remove decimal places (using the right arrow icon)
7. Rename the new Sheet to ‘Enjoyment Pivot’ (Double click Sheet tab at the bottom to rename)

8. Now repeat the above choosing Built a relationship with their mentor in place of the Enjoyed the sessions, renaming the new sheet created ‘Relationship Pivot’.


[bookmark: _Toc219282731]Exercise 2: Creating a Pivot Chart

1. Using the Relationship pivot, click on the Pivot table analyse tab and then select Pivot Chart on the top menu (towards the right). Create a Stacked bar chart to compare the prisons performance.
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2. Add the Musical experience field to the Filter area of the Pivot table – this should now appear on your chart.  Do the building a relationship with your mentor results differ depending on whether participants did or did not have prior musical experience?



[bookmark: _Toc219282732]Exercise 3: GETPIVOTDATA formula 
Bringing data from one sheet to another in a Summary sheet
The GETPIVOTDATA() formula in Excel is like a smart query tool that lets you pull specific values from a PivotTable based on its structure—not just cell location

1. In the Summary sheet, create a Get Pivot Data formula in the top cell of the Enjoyment Column (for Belmarsh Prison) by clicking in the cell and entering =

2. Then go to the Enjoyment Pivot Sheet and click on the cell with the results for Belmarsh prison and ‘1 Really Enjoyed’.  Now click on the + sign and click the cell with the results for Belmarsh prison and ‘2 Enjoyed’. Press Enter.

3. Copy this formula to remaining rows and you’ll see an error. In the Formula in the next cell down, change the Prison name to “HMP Brixton” (type this in, in the formula bar, overriding HMP Belmarsh in the 2 places it occurs)

4. In the next cell down, this time remove the Prison name (including the speech marks  “ ”) and replace with the cell reference for the Prison name (in the Prison column in the Summary sheet) that you want to replace it with (in this case HMP Manchester – cell A6) Again, you will need to do this twice – for each instance that the Prison name occurs in the formula.

5. Repeat for the ‘Built a relationship with their mentor’ data.



[bookmark: _Toc219282733]Exercise 4: COUNTIF formula
This Counts the number of cells within a range that meet the given condition.
1. Still in the Summary sheet, use the COUNTIF formula to bring in data for the respective prisons from the Prison info sheet into the Number of mentors column. 
2. Follow the COUNTIF format below:
[image: ]
For this scenario you’ll need to use: 
	=COUNTIF(All_Participants[Prison], A4)


Here, the formula refers to the Table name followed by the column header which is denoted in square brackets, and it is counting number of times that the value in cell A4 appears in that range.
3. Copy down the formula. 

	COUNTIF formula explained

	
	



	COUNTIF (range,criteria)

	

	
	=COUNTIF(All_Participants[Prison], A4)

	

	The formula broken down into its parts

	Part
	Description
	Example

	range
	The group of cells you want to evaluate
	We want to work out how many participants there are from each prison and return the number to our summary sheet, so our range is column B in our 'All participants' sheet where the prison that each participant is in is listed. So: All_Participants[Prison]

	criteria
	This is the condition which determines which cells we want to count
	We want to work out how many participants came from Belmarsh so our criteria is the cell reference for Belmarsh: cell A4




[bookmark: _Toc219282734]Exercise 5: XLOOKUP formula
This formula searches a range of cells or an array for a match and returns the corresponding item from a second range or array. By default, an exact match is used.
3. In the Summary sheet, use XLOOKUP to bring in data for the respective prisons from the Prison info sheet into the Number of mentors column. 

4. Follow the XLOOKUP format below[image: ]  
For this scenario you’ll need to use:
=XLOOKUP(A4, (Prison_Info[Prison]), (Prison_Info [Number of Mentors]))
5. Then copy the formula down.


	XLOOKUP formula explained

	
	



	XLOOKUP(lookup_value, lookup_array, return_array, [if_not_found], [match_mode], [search_mode])

	

	
	=XLOOKUP(A4, (Prison_Info[Prison]), (Prison_Info[Number of Mentors]))
=XLOOKUP(A4, (Prison_Info[Prison]), (Prison_Info[Category]))

=XLOOKUP(A4, (Prison_Info[Prison]), (Prison_Info[Category]), "not found",0,1)

	

	The formula broken down into its parts

	Part
	Description
	Example

	lookup_value
	The value you want to find
	We're looking for the number of mentors volunteering at each prison. First in our list is “Belmarsh” so the cell reference for Belmarsh - cell A4 - is your lookup_value.

	Lookup-array
	The range or array where Excel will search for the look up value
	We need to tell Exel the name of the sheet and the column we want to look in, which is in column A of the Prison info sheet which we would write as follows: (Prison_Info[Prison])

	Return-array
	The range or array where Excel will look in to return a value from if there is a match with the look up value
	We want to find out the number of mentors in Belmarsh. This information is in the Prison info sheet in column F so we need to add (Prison_Info[Category]) for the return array referencing the Table and Column

	[if_not_found]
	Optional: this is to tell Excel what it should return if there is no match
	Usually "not found" or blank - denoted by " " work for this

	[match mode]
	Optional: this is to tell Excel how close the match needs to be
	0 = Exact match (default)
-1 = Exact match or next smaller item
1 = Exact match or next larger item
2 = Wildcard match (supports * and ?)

	[search mode]
	Optional: this is to tell Excel which way to search
	1 = Search from first to last (top to bottom). (Default)
-1 = Search from last to first (bottom to top).




[bookmark: _Toc219282735]

Session 3 – Bringing data together with Power Query
Power Query is a data transformation tool built into Excel and Power BI that lets you connect to data sources, clean and reshape data, and automate repetitive tasks—all without writing code 

[bookmark: _Toc219282736]Exercise 1: Creating queries
1. Click on the table
2. On the data tab select From Table/range
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3. Check the query has the prison name 
4. On the home tab, select Close and Load to
[image: A screenshot of a computer
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5. Under the Import data options select Only Create Connection
6. Click on OK
[image: A screenshot of a computer
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7. Repeat for the other 3 Prisons

[bookmark: _Toc219282737]Exercise 2: Appending queries
1. Open the Query editor on the Data tab by going to Get Data and selecting Launch Power Query Editor.
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2. On the Home tab, select the option Append Queries as New [image: A screenshot of a computer
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3. Select the 4 Prison queries by clicking on them  and then on Add>> so that all 3 queries are in the Tables to append box
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4. Click on OK
5. A new query will appear on the left called Append1[image: A screenshot of a computer
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6. Double click on Append 1 or right click and select rename, and rename it to All participants
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7. On the Home tab click on the Close & Load button
[image: A screenshot of a computer
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8. You should now have a new sheet called All participants in your workbook
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[bookmark: _Toc219282738]

Exercise 3: Adding source data and refreshing queries
1. Add a row of data for a new participant to any of the 3 prison tables
2. Refresh the query either individually by clicking on the refresh icon next to the query name 
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Or by clicking on Refresh all on the Data tab
[image: A screenshot of a computer
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